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Configuring Application

Integration for PowerDOCS

In This Appendix

This chapter explains the steps necessary to configure and use 
applications with PowerDOCS. These steps assume that you already 
have a DOCS library set up. If you do not, see Chapter 7, “Library 
Maintenance,” of the DOCSFusion Setup and Administration Guide.
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Steps Necessary to Set Up Application Integration 
with PowerDOCS

1. Determine whether the applications you want to set up with 
PowerDOCS are integrated using Interceptor, Passive Integration, 
or ODMA (Open Document Management API). See “Integration 
Methods” on page 75, to determine how your applications are 
integrated.

2. Use Application Maintenance to add launch methods for 
applications that will use new DDE (Dynamic Data Exchange) 
settings with PowerDOCS. See “Applications Using DDE Settings” 
on page 77, for which applications need new launch methods for 
use with PowerDOCS. 

3. If you want to integrate applications that use ODMA, see 
“Integrating Applications with ODMA” on page 99.

4. If you want to integrate applications that use Interceptor, see 
“Integrating Applications with Interceptor” on page 99.

5. After you have turned on the applications in Interceptor that you 
want your users to have access to, see “Exporting the Interceptor 
Settings” on page 113, for sharing those settings with your users.

I M P O R T A N T It is strongly recommended that you not use Application Integration
with PowerDOCS and DOCS Open on the same workstation.
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Integration Methods

There are several ways to integrate applications with PowerDOCS:

• Interceptor—an integration method that monitors when Open and 

Save As dialog boxes are called.  Applications monitored through 

Interceptor should be set to Full Integration- see Chapter 8, 

“Library Maintenance,” of the DOCSFusion Setup and 

Administration Guide.

• ODMA—a document management integration method built into 

applications by their vendors. 

• Directory Monitoring—a method that tracks documents created in 

applications not integrated with Interceptor, ODMA, or Passive 

Integration.  You will be prompted to profile the document on 

saving the document to a monitored directory. To set up an 

application to use Directory Monitoring, see Chapter 7, “Library 

Maintenance,” of the DOCSFusion Setup and Administration 

Guide.

• Passive Integration—an integration method that allows you to 

profile Microsoft Word 97 and 2000, Microsoft Excel 97 and 2000, 

Microsoft Project 98 and 2000, and Adobe Acrobat 4.0 documents 

in PowerDOCS via a DOCS menu that is added to the application. 

You can bypass PowerDOCS and save in the native application 

using standard menus.  For more information on Passive 

Integration, see Chapter 8 of the PowerDOCS User’s Guide.

Table A.1 lists applications supported for use with PowerDOCS, 

charted by integration type and operating system.

N O T E The ability to use native dialog boxes may be disabled by your
PowerDOCS administrator.
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Table A.1 Application Integration by Operating System

Application Integration Type Windows 
95 & 98

Windows 
NT

Windows 
2000

Adobe Acrobat Exchange
3.0

Interceptor X X X

Adobe Acrobat 4.0 Passive Integration X X X

Adobe Acrobat Reader
4.0x

Interceptor X X X

AutoCAD R14 Interceptor X X X

Corel Presentations 8 Interceptor X X X

Corel Presentations 9 Interceptor X X X

Corel Quattro Pro 8 Interceptor X

Corel Quattro Pro 8 ODMA X X

Quattro Pro 9 Interceptor X X X

Corel WordPerfect 8 Interceptor X

Corel WordPerfect 8 ODMA X X

WordPerfect 9 Interceptor X

WordPerfect 9 ODMA X X

Lotus 1-2-3, 97 Interceptor X X X

Lotus 1-2-3, ME Interceptor X X X

Microsoft Excel 97 Interceptor X X X

Microsoft Excel 97 Passive Integration X X X

Microsoft Excel 2000 Interceptor X X X

Microsoft Excel 2000 Passive Integration X X X

Microsoft PowerPoint 97 ODMA X X X
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Applications Using DDE Settings

To set up certain applications with PowerDOCS, you must create an 
additional set of launch methods to enter new Dynamic Data Exchange 
(DDE) settings used with PowerDOCS. For example, if you have a 
launch method for Excel already set up in Application Maintenance for 
use with DOCS Open, you may need to create a new launch method for 
use with PowerDOCS that is identical to the original launch method 
except for the specific DDE settings. We recommend that you change 
the description field to “Excel - PowerDOCS,” to differentiate between 
the two launch methods. 

Application Integration Type Windows 
95 & 98

Windows 
NT

Windows 
2000

Microsoft PowerPoint
2000

ODMA X X X

Microsoft Project 98 Passive Integration X X X

Microsoft Project 2000 Passive Integration X X X

Microsoft Word 97 ODMA X X X

Microsoft Word 97 Passive Integration X X X

Microsoft Word 2000 ODMA X X X

Microsoft Word 2000 Passive Integration X X X

Visio 5 Interceptor X X X

Visio 2000 Interceptor X X X

N O T E Before integrating applications with PowerDOCS, verify that the
application settings listed in Library Maintenance match those
shown in the section entitled “DDE Settings for Specific
Applications” on page 80.

Corel Suite applications are configured slightly different. Refer to
“Application Integration for Corel Applications” on page 89.
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The applications that require specific DDE settings are:

• Adobe Acrobat Exchange 3.0.x

• Adobe Acrobat 4.0x 

• Adobe Acrobat Reader 4.0x

• Microsoft Excel 97 and 2000

• Microsoft Word 97 and 2000

• Microsoft PowerPoint 97 and 2000

• Microsoft Project 98 and 2000

• Corel WordPerfect 8.0 and 9.0

• Corel Presentations 8.0 and 9.0

• Corel Quattro Pro 8.0 and 9.0

• Visio 5 and 2000

• Lotus 1-2-3, 97

• Lotus 1-2-3, ME

To create the additional launch methods:

1. From the Windows Start menu, select Programs>DOCSFusion 
Services>DOCS Admin Tools>Library Maintenance.

2. Double-click the Applications icon.

3. From the Application Maintenance Select dialog box, highlight the 
application that needs an additional PowerDOCS launch method 
and click OK.

4. Click Launch Methods from the Application Maintenance dialog 
box.

5. Select a launch method and click Copy.
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6. In order to differentiate between the DOCS Open launch method 
and the PowerDOCS launch method, edit the Launch Method 
Description to refer to PowerDOCS. For example, edit the Excel 97 
Launch Method Description as “Excel 97 - (PowerDOCS).” 

7. Click DDE Settings. 

8. Specify the new DDE settings, listed in Table A.2 through Table 
A.23, in the Application DDE Settings dialog box. 

For more instructions on setting up applications in Application 
Maintenance, see Chapter 8, “Library Maintenance,” in the 
DOCSFusion Setup and Administration Guide. 

I M P O R T A N T You must refresh the DOCSFusion cache when changes have
been made in Library Maintenance. To do this, go to the
DOCSFusion server and access the DOCSFusion Server Manager.
Select the Caches tab and click Refresh All. The next time you
launch PowerDOCS, your changes will take effect.

R E M I N D E R It is strongly recommended that you not use Application Integration
with PowerDOCS and DOCS Open on the same workstation.
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DDE Settings for Specific Applications

DDE Settings for
Adobe Acrobat

Table A.2 Acrobat Exchange 3.0.x Launch Method Settings

Acrobat Exchange 3.0.x DDE Settings - Open

Acrobat Exchange 3.0.x DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

%FULLPATH

Application Name ACROVIEW

Topic Name CONTROL

Command [FileOpen(“%1”)]

Command (not running) [FileOpen(“%1”)]

Application Name AIM

Topic Name AcroExch.Document

Command Print

Command (not running) Print
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Table A.3 Acrobat 4.0x Launch Method Settings

Acrobat 4.0x DDE Settings - Open

Acrobat 4.0x DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

%FULLPATH

Application Name ACROVIEW

Topic Name CONTROL

Command [FileOpenEx(“%1”)]

Command (not running) [FileOpenEx(“%1”)]

Application Name ACROVIEW

Topic Name CONTROL

Command [FilePrintSilentEx("%1")]

Command (not running) [FilePrintSilentEx("%1")][AppQuit]
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Table A.4 Acrobat Reader 4.0x Launch Method Settings

Acrobat Reader 4.0x DDE Settings - Open

Acrobat Reader 4.0x DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

%FULLPATH

Application Name ACROVIEW

Topic Name CONTROL

Command [FileOpenEx(“%1”)]

Command (not running) [FileOpenEx(“%1”)]

Application Name ACROVIEW

Topic Name CONTROL

Command [FilePrintSilentEx("%1")]

Command (not running) [FilePrintSilentEx("%1")]
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Visio DDE
Settings

To integrate Visio 5 and Visio 2000 you will need to disable ODMA 
integration in addition to using the specified DDE settings.

1. Disable ODMA for each application by adding the following Keys 
to the Windows Registry.

HKCR\VISIO 

HKCR\VISIO\ODMA32

To make this task easier, Registry files have been provided. The files are 
found in the Tools>PowerDOCS directory on the Fusion Family CD.  
As the administrator, you can make a master registry file and provide it 
to your users.  Please refer to “Exporting the Registry File” on page 65 
and “Importing a Registry File” on page 115.

Table A.5 Visio 5 Launch Method Settings

Visio 5 DDE Settings - Open, None
Visio 5 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

“%FULLPATH”

Application Name AIM

Topic Name Visio.Drawing.5

Command Print

Command (not running) Print
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Table A.6 Visio 2000 Launch Method Settings

Visio 2000 DDE Settings - Open, None
Visio 2000 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

“%FULLPATH”

Application Name AIM

Topic Name Visio.Drawing.6

Command Print

Command (not running) Print
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DDE Settings for
Microsoft Office

Applications

Table A.7 Microsoft Excel 97 and 2000 Launch Method 
Settings 

Microsoft Excel DDE Settings - Open

Microsoft Excel DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

Application Name EXCEL

Topic Name SYSTEM

Command [open("%1")]

Command (not running) [open("%1")]

Application Name EXCEL

Topic Name SYSTEM

Command [open("%1")][print?()][close()]

Command (not running) [open("%1")][print?()][quit()]

N O T E To execute a Print command from the Recently Edited documents
list without a pause at the printer setup dialog box, remove the ?
from the command syntax.
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Table A.8 Microsoft Word 97 and 2000 Launch Method 
Settings

Microsoft Word DDE Settings - Open

Microsoft Word DDE Settings - Print 

Integration Type ODMA Compliant

Command Line 
Parameters

/ND

Application Name WINWORD

Topic Name SYSTEM

Command [FileOpen("%1")]

Command (not running) [FileOpen("%1")]

Application Name WINWORD

Topic Name SYSTEM

Command [FileOpen("%1")][FilePrint 0][DocClose 2]

Command (not running) [FileOpen("%1")][FilePrint 0][FileExit 2]
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Table A.9 Microsoft PowerPoint 97 and 2000 Launch Method 
Settings

Microsoft PowerPoint DDE Settings - Open, None
Microsoft PowerPoint DDE Settings - Print

Integration Type ODMA Compliant

Command Line 
Parameters

%FULLPATH

Application Name AIM

Topic Name PowerPoint.Show.8

Command Print

Command (not running) Print
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Table A.10 Microsoft Project 98 and 2000 Launch Method 
Settings (Passive Integration Only)

Microsoft Project DDE Settings - Open

Microsoft Project DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

Application Name WINPROJ

Topic Name SYSTEM

Command [FileOpen“%1”]

Command (not running) [FileOpen“%1”]

Application Name WINPROJ

Topic Name SYSTEM

Command FileOpen “%1”:FilePrint 1, 32767

Command (not running) FilePrint 1,32767:FileExit 0
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Application Integration for Corel Applications

When configuring integration for Corel Suite applications, you must 
take into account both the application version and the operating 
system of the computer on which the application will be running.

When configuring DDE settings for Corel WordPerfect 8.0 and 9.0, 
Presentations 8.0 and 9.0, and Quattro Pro 9.0, you will need to set up 
two launch methods, one for Open and another for Print.  Quattro Pro 
8.0 only requires one launch method.

Corel Suite
Application

Integration for
Windows 95,

98, and
Windows NT

On a Windows 95, Windows 98 or Windows NT system, Quattro Pro 
8.0 and WordPerfect 8.0 and 9.0 can be integrated without further 
modifications other than the appropriate launch methods.  

To integrate Quattro Pro 9.0, Presentations 8.0, and Presentations 9.0 
you will need to disable ODMA integration and turn off enhanced 
dialog boxes.  See “Disabling ODMA Integration for Corel Suite 
Applications” on the next page

Corel Suite
Application

Integration for
Windows 2000

On Windows 2000 systems, all Corel Suite applications require you to 
disable ODMA integration and turn off enhanced dialog boxes.

Instructions for disabling ODMA and turning off enhanced dialog 
boxes are listed on the next page.  On the pages following these 
instructions the specific launch method/DDE settings that need to be 
configured are listed.

IMPORTANT The Launch methods listed on the following pages may instruct you to
set the launch method to ODMA Compliant. If you are disabling ODMA
integration, you must set the launch method to Full Integration as
instructed in step 3, below.
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Disabling ODMA Integration for Corel Suite Applications

1. Disable ODMA for each application by adding the following Keys 
to the Windows Registry.

WordPerfect:

[HKEY_CLASSES_ROOT\WORDPERFECT]

[HKEY_CLASSES_ROOT\WORDPERFECT\ODMA32]

Quattro Pro:

[HKEY_CLASSES_ROOT\QPW]

[HKEY_CLASSES_ROOT\QPW\ODMA32]

Presentations: 

[HKEY_CLASSES_ROOT\PRESENTATIONS]

[HKEY_CLASSES_ROOT\PRESENTATIONS\ODMA32]

To make this task easier, Registry files have been provided. The 
files are found in the Tools>PowerDOCS directory on the Fusion 
Family CD.  

As the administrator, you can make a master registry file and 
provide it to your users.  Please refer to “Exporting the Registry 
File” on page 65 and “Importing a Registry File” on page 115.
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2. Within each application, clear the Use enhanced file dialogs 
option:  

In WordPerfect select Tools > Settings > Files.  Clear the Use 
enhanced file dialogs selection from the Document tab.  

In Quattro Pro, select Tools > Settings.  From the File Options tab, 
clear the Use enhanced file dialogs selection.

In Presentations, select Tools > Settings > Environment.  From the 
Options tab, clear the Use enhanced file dialogs selection.

3. Go to Library Maintenance and edit the launch methods for each 
application to match the application settings shown below.

4. Enable the launch method in Interceptor.  Refer to “Steps 
Necessary to Set Up Application Integration with PowerDOCS” 
on page 74.

Specific DDE
Settings for
Corel Suite

Applications

Table A.11 Corel WordPerfect 8.0 Launch Method Settings - 
Open

Corel WordPerfect 8.0 DDE Settings - Open

Integration Type ODMA Compliant for Windows 9x & NT

Full Integration for Windows 2000

Command Line 
Parameters

/ddeex

Application Name WPWin8_Macros

Topic Name COMMANDS

Command Display(1) FileOpen("%1") WPActivate

Command (not running) Display(1) FileOpen("%1") WPActivate
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Table A.12 Corel WordPerfect 8.0 Launch Method Settings - 
Print

Corel WordPerfect 8.0 DDE Settings - Print

Integration Type ODMA Compliant for Windows 9x & NT

Full Integration for Windows 2000

Command Line 
Parameters

/ddeex /smin :

Application Name WPWin8_Macros

Topic Name COMMANDS

Command FileOpen("%1") PrintFullDoc()
CloseNoSave(1)

Command (not running) FileOpen("%1") PrintFullDoc()
CloseNoSave(1)
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Table A.13 WordPerfect 9.0 Launch Method Settings - Open

WordPerfect 9.0 DDE Settings - Open

Table A.14 WordPerfect 9.0 Launch Method Settings - Print

Integration Type ODMA Compliant for Windows 9x & NT

Full Integration for Windows 2000

Command Line 
Parameters

/ddeex

Application Name WPWin9_Macros

Topic Name COMMANDS

Command Display(1) FileOpen("%1") WPActivate

Command (not running) Display(1) FileOpen("%1") WPActivate

Integration Type ODMA Compliant for Windows 9x & NT

Full Integration for Windows 2000

Command Line 
Parameters

/ddeex /smin :
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WordPerfect 9.0 DDE Settings - Print

Table A.15 Corel Quattro Pro 8.0 Launch Method Settings

Corel Quattro Pro 8.0 DDE Settings - Open

Corel Quattro Pro 8.0 DDE Settings - Print

Application Name WPWin9_Macros

Topic Name COMMANDS

Command FileOpen("%1") PrintFullDoc()
CloseNoSave(1)

Command (not running) FileOpen("%1") PrintFullDoc()
CloseNoSave(1)

Integration Type ODMA Compliant for Windows 9x & NT

Full Integration for Windows 2000

Command Line 
Parameters

Application Name QPW

Topic Name System

Command {FileOpen “1%”}

Command (not running) {FileOpen “1%”}

Application Name QPW

Topic Name System

Command {FileOpen “%1”}{Print?}{FileClose 0}

Command (not running) {FileOpen “%1”}{Print?}{FileExit 0}
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Table A.16 Quattro Pro 9.0 Launch Method Settings - Open

Quattro Pro 9.0 DDE Settings - Open

Table A.17 Quattro Pro 9.0 Launch Method Settings - Print

Quatto Pro 9.0 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

%FULLPATH

Application Name QPW

Topic Name SYSTEM

Command [open("%1")]

Command (not running) [open("%1")]

Integration Type Full Integration

Command Line 
Parameters

/dde

Application Name QPW

Topic Name SYSTEM

Command [print("%1")]

Command (not running) [print("%1")]
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Table A.18 Corel Presentations 8.0 Launch Method Settings - 
Open

Corel Presentations 8.0 DDE Settings - Open

Table A.19 Corel Presentations 8.0 Launch Method Settings - 
Print

Corel Presentations 8.0 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

/ddeex

Application Name PRESENTATIONS

Topic Name COMMAND

Command ShellFileOpen(“%1”) PRActivate()

Command (not running) ShellFileOpen("%1") PRActivate()

Integration Type Full Integration

Command Line 
Parameters

/ddeex /pt

Application Name PRESENTATIONS

Topic Name COMMAND

Command ShellPrintTo(“%1”)

Command (not running) ShellPrintTo(“%1”) FileExit()
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Table A.20 Corel Presentations 9.0 Launch Method Settings - 
Open

Corel Presentations 9.0 DDE Settings - Open

Table A.21 Corel Presentations 9.0 Launch Method Settings - 
Print

Corel Presentations 9.0 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

/ddeex

Application Name PRESENTATIONS

Topic Name COMMAND

Command ShellFileOpen(“%1”) PRActivate()

Command (not running) ShellFileOpen("%1") PRActivate()

Integration Type Full Integration

Command Line 
Parameters

/ddeex /pt

Application Name PRESENTATIONS

Topic Name COMMAND

Command ShellPrintTo(“%1”)

Command (not running) ShellPrintTo(“%1”) FileExit()
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DDE Settings for
Lotus 1-2-3

Lotus 1-2-3 97 and Lotus 1-2-3 ME require 2 launch method settings, 
one for Open and one for Print.

Table A.22 Lotus 1-2-3 Launch Method Settings - Open

Lotus 1-2-3 DDE Settings - Open, None
Lotus 1-2-3 DDE Settings - Print

Table A.23 Lotus 1-2-3 Launch Method Settings - Print

Lotus 1-2-3 DDE Settings - Open, None
Lotus 1-2-3 DDE Settings - Print

Integration Type Full Integration

Command Line 
Parameters

%FULLPATH

Application Name AIM

Topic Name 123Worksheet

Command Print

Command (not running) Print

Integration Type Full Integration

Command Line 
Parameters

-P %FULLPATH

Application Name AIM

Topic Name 123Worksheet

Command Print

Command (not running) Print
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Integrating Applications with ODMA

ODMA is a document management integration method built into 
applications by their vendors.  Some programs, such as Microsoft 
Word, can use either ODMA or Passive Integration.  The two 
integration types should not be combined.

Integrating Applications with Interceptor

Interceptor is installed with PowerDOCS. There are two ways that 
applications can be intergrated using Interceptor, using the Interceptor 
Learning Tool or using Interceptor.  In all cases,  a launch method must 
be created in Library Maintenance.

The Interceptor 
Learning Tool

The Interceptor Learning Tool
(ILTWizard.exe) is used to integrate
applications installed on the user’s
workstation. In most cases, these
applications are not in the default list
provided in Library Maintenance.

The Interceptor Learning Tool is located in
the ...Tools\PowerDOCS\ 
Interceptor Learning Tool folder
on the Fusion Family CD. See
ILTWizard.PDF for more information.

Interceptor Interceptor is the module that monitors
when Open and SaveAs dialog boxes are
called for specific applications integrated
with PowerDOCS. It is represented by the
system tray icon that is displayed when
the user starts PowerDOCS.

Applications that are not currently
integrated can be added to Interceptor
manually.
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The Interceptor Module

You can use PowerDOCS Interceptor to:

• Enable or disable applications monitored by Interceptor.

• Edit Launch Method settings. 

• Export the settings to a registry file that can be run on users’ 
workstations to easily duplicate settings.

• Configure new applications.

Each of these tasks is described in the sections below. To configure a 
new application for integration with Interceptor, you can use the 
Interceptor Learning Tool or configure a new application directly from 
Interceptor. 

Launching the
PowerDOCS
Interceptor

1. Locate the Interceptor executable, INTERCEPTOR.EXE, in your 
PowerDOCS folder (by default, …\Program Files\ 
Hummingbird\PowerDOCS) and double-click it.  If you are not 
logged in to PowerDOCS, the login dialog box appears. 

2. Once you are logged in to PowerDOCS, the Interceptor program 
icon is displayed along the bottom right corner of the desktop, in 
the system tray.

N O T E If you are logged in to PowerDOCS, the Interceptor will already be
running. Proceed to step 3.

Figure A.1

The Interceptor Icon
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3. Double-click the Interceptor icon in the system tray. The 
PowerDOCS Interceptor dialog box appears. It contains a list of 
launch methods that are stored in Application Maintenance. The 
launch methods for the library you are logged in to are displayed 
by default.You can switch to a remote library by clicking the down 
arrow of the Library combo box. 

Figure A.2

PowerDOCS Interceptor

N O T E Only applications that use Full Integration are listed.
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Configuring New Applications for Interceptor 

The PowerDOCS Interceptor allows you to integrate new applications 
that do not already exist in Interceptor’s list of launch methods.  For 
both methods, you must create a launch method in Library 
Maintenance, using the DOCS Admin Tools.

You can integrate new applications in one of two ways:

• Use Interceptor directly or 

• Use the Interceptor Learning Tool (ILT), located in the 
Tools>PowerDOCS>Interceptor Learning Tool folder on the 
Fusion Family CD.  Instructions for using the ILT Wizard are 
found in ILTWizard.PDF.

Integrating
New

Applications
from the

PowerDOCS
Interceptor

You can integrate a new application directly from the PowerDOCS 
Interceptor. Once you have completed the following steps, the 
application you configured will be monitored by Interceptor. You can 
disable integration with applications at any time.

Creating Launch Methods for Interceptor Applications

Before you can add and integrate a new application, you must create a 
launch method for that application in Library Maintenance. You can 
access Library Maintenance by using the DOCS Admin Tools.

N O T E After creating launch methods and enabling them in Interceptor, you
should refresh the DOCSFusion Server cache and the PowerDOCS
workstation. The workstation may be refreshed by pressing F5 or by
deleting the Cache directory.
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To create a launch method for a new application:

1. From Library Maintenance, double-click the Applications icon. 

2. From the Application Maintenance Select dialog box, click the 
New button. 

3. Complete the Application Maintenance dialog box as described 
below:

Application ID: Enter an ID that is appropriate and logical. 
You will later use this ID when adding a new application to 
Interceptor.

Description: Enter the Application name in this field.

Filing Scheme: Select the appropriate filing scheme from the 
drop-down list (typically, Enhanced).

File Types: Click the table lookup (ellipsis) button for this 
field and click Add to enter file extensions that are accepted by 
this application.

4. Click OK, then click the Options button. From Application 
Options, make sure that Shows on Desktop is selected.

5. Click Close from Application Options, then click the Launch 
Methods button.

6. From the Application Launch Methods Select window, click the 
New button. 

7. The Application Launch Methods dialog box appears. Complete 
this dialog box as described below:

Description: Specify the Application name in this field.

Location: Specify the drive letter and directory for this 
application. Use the table lookup (ellipsis) button to browse 
for the correct directory.
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Default Directory: Specify the same drive letter and directory 
that you entered in the Location field.

Integration: Select Full Integration from this drop-down list. 
In order for Interceptor to monitor new applications, you 
must select Full Integration.

8. Click OK.  If this application requires specific DDE settings, click 
the DDE Setting button.

9. Enter the DDE setting information into the fields and click OK, 
then click Close.

10. Click Close to return to the Application Launch Methods Select 
dialog box. Your new launch method appears in the Description 
window of this dialog box.

11. Continue to click Close until you return to the original 
Application Maintenance Select dialog box. Your new launch 
method appears in the Application ID column. 

12. Click Close and then File>Exit to close Library Maintenance.

You are now ready to add this application to Interceptor and 
should proceed with the steps in the following section. For more 
information about Library Maintenance, refer to Chapter 7, 
“Library Maintenance,” of the DOCSFusion Setup and 
Administration Guide.
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Adding New
Applications to

Interceptor

To configure a new application in the Interceptor:

1. Launch the Interceptor, using the instructions in “Launching the 
PowerDOCS Interceptor” on page 100. The PowerDOCS 
Interceptor window appears, displaying all applications that are 
currently configured to work with Interceptor. The application 
you are configuring will not appear in the list until you complete 
the subsequent steps and restart Interceptor.

2. Click the Application Settings tab. This window will be empty if 
you have never configured a new application in Interceptor. If you 
have previously integrated new applications, this list appears in the 
active window. Click Add to add a new application.

3. With the Common Properties tab selected, complete the following 
fields:

Application ID: Specify the Application ID you chose when 
creating this application’s launch method in Application 
Maintenance. If these Application IDs do not match, 
PowerDOCS may have trouble reconciling the application 
with its launch method.

Description: Specify the application name in this field.

Keyword: Specify the Application ID you chose when creating 
this application’s launch method. PowerDOCS attempts to 
match the value(s) in the Keyword field to words in the 
Launch Methods.

4. Click the Window Properties tab. This tab has two Autodetect 
check boxes that are selected by default. We highly recommend 
leaving these boxes selected. If you clear these boxes, you will have 
to enter all application settings manually. If you leave them 
checked, Interceptor attempts to automatically detect all settings. 

5. Click the Application Dialogs tab to display the Dialogs window. 
This window will be empty until you add commands to be 
integrated with Interceptor.
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6. Click Add to display the Dialog window. Fill out the fields as 
described below.

Dialog Type: Select the dialog type that most closely matches 
the nature of the dialog box you are integrating. 

Dialog Caption: Type the caption title of the dialog box. 

Not full caption: Select this check box if you want to use the 
same settings for several dialog boxes with equal functionality 
and similar headings. In the Dialog Caption field, type the 
common part of the headings and select Not full caption.

Open Select this type if you want the Search Results 
dialog box presented and the selected 
document opened.

Save As Select this type if you want the Document 
Profile form displayed so the user can profile 
and save the open document. When this type 
is selected, the original document is replaced 
by the new one.

Import Select this type if you want the Search Results 
dialog box presented and the selected 
document opened into the current 
document. Some applications may not 
support Import and Export.

Export Select this type if you want the Document 
Profile form displayed so the user can profile 
and save the exported document. Some 
applications may not support Import and 
Export. When this type is selected, the 
original document remains open. This is 
useful for MS Outlook and for graphics 
programs where you want to perform a “Save 
Copy As.”
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Autodetect: This check box is selected by default, and it is 
strongly recommended that you leave it selected.

7. Click OK to save your settings. The dialog box you configured 
appears in the Dialogs window. You can repeat step 6 to configure 
other commands in this application.

8. When you have finished integrating commands, click OK and 
close the Application Settings dialog box.

9. Your new application should appear in the Application Settings 
list.

10. Enable the application in Interceptor.  Refer to “Enabling 
Applications Within Interceptor” on page 107.

Enabling
Applications

Within
Interceptor

After creating a launch methods in Application Maintenance and in 
Intereceptor, complete the following steps to enable the integration.

1. Launch the PowerDOCS Interceptor, as described in “Launching 
the PowerDOCS Interceptor” on page 100.

Figure A.3

PowerDOCS Interceptor 
Launch Methods tab
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2. From the Launch Methods tab of the PowerDOCS Interceptor 
window, shown in Figure A.3, highlight the launch method for the 
application that you want to integrate and click Enable. 

The following dialog box is displayed. 

• The Application ID and Description fields are filled in by default.

• Click the Browse button to ensure that your program path is 
correct. The Open dialog box appears. If you do not have the full 
path to the application in your system path, select the Full Path 
radio button before you select the executable (*.EXE) file. 

I M P O R T A N T Remember to select the launch method that applies to
PowerDOCS, not DOCS Open.

Figure A.4

Launch Method Settings 
dialog box



ENABLING APPLICATIONS WITHIN INTERCEPTOR

APPENDIX A  CONFIGURING APPLICATION INTEGRATION FOR POWERDOCS      109

A

If this information is in your system path, you can accept the 
default of Only File Name.

3. Click Open.  

4. In the Launch Method Settings dialog box, click the down arrow 
of the Use settings for drop-down list and select the correct 
application from the list.

5. Click OK to enable Interceptor to monitor the application’s 
launch method. A green dot is then displayed next to the 
application, indicating that the application is now set to be 
monitored by Interceptor. 

If the Program Path on the users’ individual workstations is 
different from the Location defined in Application Maintenance, 
you need to point Interceptor to the application’s executable. For 
more information, see “Editing the Launch Method Settings” on 
page 110. 

6. Click Close to exit Interceptor.

Figure A.5

The Open dialog box
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Once you have enabled each application that you want integrated, you 
can create a registry file that can be run on users’ workstations to 
duplicate the integration information that you have created on your 
workstation. See “Exporting the Interceptor Settings” on page 113.

Disabling
Integration

with
Interceptor

If you want to disable integration for an application that you have 
integrated with Interceptor, complete the following steps.

1. Launch the PowerDOCS Interceptor as described in “Launching 
the PowerDOCS Interceptor” on page 100.

2. Select the application that you want to disable from the Launch 
Methods tab of the PowerDOCS Interceptor dialog box.

3. Click Disable. The green dot to the left of the application 
description will change to a red dot indicating that the application 
launch method will no longer be monitored by Interceptor. 

Editing the
Launch Method

Settings

The Interceptor allows you to edit the path to an application that 
Interceptor will monitor. When you edit the launch method settings 
from Interceptor, your edits do not apply to Application Maintenance 
in Library Maintenance. You are only editing the path that Interceptor 
will monitor. This allows more flexibility in the location of your users’ 
integrated applications. 

N O T E There are some applications that require specific Launch Method
or Registry settings. Please refer to “DDE Settings for Specific
Applications” on page 80.

N O T E A yellow dot to the left of an application description means a setting
(launch method) exists in the registry but is missing or incorrect in
the database.

R E M I N D E R You need launch methods configured in both Application Maintenance
and Interceptor.



EDITING THE LAUNCH METHOD SETTINGS

APPENDIX A  CONFIGURING APPLICATION INTEGRATION FOR POWERDOCS      111

A

For example, suppose you selected Microsoft Excel to be monitored by 
Interceptor and the Location defined in the Application Launch 
Methods is:

 C:\Program Files\Microsoft\Office\Excel.EXE

If you have  users who have Excel installed on their D:\ drive, you would 
have multiple launch methods set up. In Interceptor, you only need to 
enable one of those launch methods. Specify only the file name of the 
executable in the Program Path field and select the Only File Name 
option on the Open dialog box, shown in Figure A.5. 

This allows Interceptor to monitor the application independent from 
where it is launched, as long as the executable is in the user's search 
path.

To edit the launch method that Interceptor will monitor:

1. From the Interceptor dialog box, select the launch method that 
you want to edit and click Edit from the Launch Methods tab. The 
Launch Method Settings dialog box is displayed.

2. Fill out the fields as described below:

Program Path: Specify the path to the application that you want 
Interceptor to monitor. The path can be a whole or partial path or 
simply the executable file name. If you have a company whose 
individual workstations have different configurations, use the 
executable file name. Click Browse to ensure that your program 
path is correct. The Open dialog box appears, shown in Figure A.5. 
If you do not have the full path to the application in your system 
path, select the Full Path radio button before selecting the 
executable (*.EXE) file. If this information is in your system path, 
you can accept the default of Only File Name.

Use Settings for: Select the appropriate launch method from this 
drop-down box. 

N O T E Click the Full Path button to save the information you enter in the
Program Path field.
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Interceptor
Settings

The Interceptor Settings tab of the PowerDOCS Interceptor dialog box 
contains three general settings that affect how Interceptor behaves 
when errors occur.

Open Document Notification: If this option is selected, users will 
be notified when an application format or a version 
incompatibility causes an error while opening a document. If this 
option is checked, and a conflict occurs, PowerDOCS will lock the 
document and release it only if you have selected Show Confirm 
on Releasing Document.

Show Confirm on Releasing Document: If you selected Open 
Document Notification, you must also check this option. If this 
option is checked, users will be prompted to release the document 
after the designated time if an error occurs while opening it.

Wait n seconds before releasing document: The default value is 
30 seconds. If you accept the default, PowerDOCS will try to open 
the document for 30 seconds before prompting you to release it. 
You can override the default value. 

After making these changes, you can export your settings to a registry 
file for your users. For more information, refer to “Exporting the 
Interceptor Settings” on page 113.

Figure A.6

Interceptor Settings tab 
of the PowerDOCS 
Interceptor
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Exporting the
Interceptor

Settings

The Export option in the PowerDOCS Interceptor enables you to 
create a registry file that you can distribute to users to duplicate the 
application integration settings you created using Interceptor. 

Only the applications that you enabled in Interceptor before creating 
the registry file will be turned on and actively integrated in the user’s 
Interceptor.

1. Launch the PowerDOCS Interceptor as described in “Launching 
the PowerDOCS Interceptor” on page 100.

2. From the Launch Methods tab of the PowerDOCS Interceptor 
dialog box, select Export. 

3. The Export Settings dialog box appears.

4. The default setting on this dialog box is All Settings. We 
recommend that you leave this selected and click Export. The Save 
As dialog box is displayed. If you select All Settings, PowerDOCS 
assigns a default file name for the registry file of 
InterceptorSettings.reg.

Figure A.7

Save As dialog 
box
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• Export Settings:

All Settings: This option exports application settings and launch 
method settings for all applications and all libraries. This is the 
most common setting when exporting a registry file. Selecting this 
option creates a registry file named InterceptorSettings.reg, 
by default.

Only Application Settings: This option exports the settings that 
relate to application properties and creates a registry file named 
InterceptorAppDB.reg, by default.

All Launch Method Settings: This option exports only the launch 
method settings for your applications and creates a registry file 
named LaunchMethodSettings.reg, by default.

Launch Method Settings for the Selected Library: This option 
exports only the enabled launch methods for the currently selected 
library and creates a registry file named LibraryName.reg, by 
default, where your library name is inserted.

5. Select a location for the registry file and click Save. 

If you do not place the registry file(s) in the PowerDOCS folder, 
place it in a location that is accessible to all users. 

N O T E Place the registry file in the PowerDOCS Install Kit directory (by
default, ..Program Files\Hummingbird\Install\ 
PowerDOCS); it will run automatically when your users install
PowerDOCS on their machines.
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Importing a
Registry File

Inform your users of the location of the registry file to be imported. 

Instruct your users to double-click the registry file(s). The following 
dialog box appears, confirming that the registry settings were installed 
on their workstation. 

Figure A.8

Registry Editor 
confirmation
message

N O T E If your users install PowerDOCS in a directory location that is
different from the computer from which you export the Interceptor
registry file, they may receive messages stating that there are no
valid launch methods for their applications. To resolve this issue
you should export and apply the Interceptor files in two parts:

Application Settings Only

All Launch Method Settings
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Restricting Users from Accessing Interceptor Settings 
and Native Dialog Boxes

By design, PowerDOCS is set up to allow users to open and save files 
both within and outside the document management system.

If you, as the PowerDOCS administrator, do not want to allow the 
users and/or certain groups in your organization to save documents 
outside of PowerDOCS, you should follow the instructions listed  
below. As the PowerDOCS Administrator, you should set up all 
applications via the Interceptor beforehand and export a registry file 
that can be accessed by the user.  See “Exporting the Interceptor 
Settings” on page 113.

1. Copy the DisableNativeDialogs.reg file from the 
…Tools\PowerDOCS directory on theFusion Family CD-ROM to 
the ..\install\PowerDOCS directory.  This file will be 
automatically merged into any workstation that runs the 
PowerDOCS Admin Kit installation program.  

This registry change will disable the option located in the 
PowerDOCS Options > Defaults > General tab called Disable 
native dialogs.  In conjunction with step 2, below, all native dialog 
boxes allowing the user to open or save to the local file system will 
be disabled. If you plan to implement this feature after your users 
have already installed PowerDOCS, you will need to instruct your 
users to import the registry file.  See “Importing a Registry File” on 
page 115.

N O T E Disabling Native Save and Open and access to Interceptor work
hand in hand. You can't disable one without disabling the other.
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2. In Library Maintenance>System Parameters and/or Groups 
Maintenance, access the Features dialog box and set the Disable 
Native Open/Save option to Yes.   

Figure A.9

Groups Maintenance
Features dialog box
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Enabling this option will result in the following:

• The Disable Native Save check box located in the PowerDOCS 
Options dialog box will be unavailable for modification.

•  The Settings option in Interceptor will be unavailable.

3. As the final step, you will need to refresh the cache at the 
DOCSFusion Server Manager.  In DOCSFusion Server Manager, 
on the Caches tab, click Refresh All to update the library 
information in DOCSFusion.

Figure A.10

Library Maintenance 
System Parameters
Features dialog box
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4. If you want to revert to allowing your users to save outside of 
PowerDOCS, instruct your users to run the 
EnableNativeDialogs.reg file, located in the 
…Tools\PowerDOCS folder on the Fusion Family CD.  

You must also return to Library Maintenance and/or Groups 
Maintenance and reset the Disable Native Save option to No. 
Remember to refresh the DOCSFusion Server Cache as described 
in step 3.

In either case, you will need to close PowerDOCS and reopen the 
application before these changes take effect.

PowerDOCS Auto-Login

You can enable the Auto-Login feature so that users can save their 
PowerDOCS password to allow quick login to the system.  As an 
administrator, you can enable this feature on a global or group level.

When using PowerDOCS on a Windows NT or Windows 2000 system, 
the ability to save the PowerDOCS password is not immediately 
available.  As an administrator you can provide registry files that will 
allow Windows NT users to save their PowerDOCS password.

Figure A.11

PowerDOCS Login dialog 
box - Windows 95 and 98

N O T E Before providing these features to your users, consider the
security issues that may result from allowing unrestricted access to
PowerDOCS.
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Disabling the
Auto-Login

Feature-
Windows 95

and 98

In Library Maintenance>System Parameters and/or Groups 
Maintenance, access the Features dialog box and set the Allow Auto 
Login to No.  Refer to Figure A.9 and Figure A.10.

Enabling and
Disabling Auto-

Login -
Windows NT

and Windows
2000

By design, the ability to save passwords for PowerDOCS  is not 
available for Windows NT users.  If your Windows NT users would like 
access to this feature, you can modify the Windows registry to allow 
auto-login by installing the registry files provided for this purpose.  The 
files are found on the …Tools\PowerDOCS folder on the Fusion Family 
CD.

The portion of the registry that is modified is: 

HKEY_CURRENT_USER\Software\Hummingbird\PowerDOCS\Core
\Plugins\Fusion\

The two files provided to turn this feature off and on are:

NT_Auto_Login_OFF.reg

NT_Auto_Login_ON.reg
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Installing PowerDOCS Macros in Microsoft Word and 
Corel WordPerfect

When you install PowerDOCS, two sets of macros are included for use 
with Microsoft Word and Corel WordPerfect.  Both macros allow the 
user to add PowerDOCS information to the footer of a document. 
Instructions for using these macros are found in Chapter 8 of the 
PowerDOCS User’s Guide.

Installing the
Microsoft Word

Macros

1. If you have previously integrated with Word and have customized 
your DOCS Open macros, you need to rename the file 
NORMAL.DOT under a different file name. You will then have a 
backup copy of your customized macros, which can be used by a 
qualified integrator to recustomize the new macros.

2. Start Word. Select File>Open. If  Word is integrated using ODMA, 
the Search Results dialog box is displayed. If you are not logged in 
to PowerDOCS, the login screen is displayed. 

3. If you use Word with ODMA integration, click Cancel to display a 
native Open dialog box. PowerDOCS displays a message box, 
asking you if you want MS Word to open a document. Click Yes to 
display the native Open dialog box. Proceed to step 5.

4. If you are using Passive Integration, you do not need to click 
Cancel. With Passive Integration installed, you only need to select 
File>Open to display a native dialog box.

N O T E Do not start the macro by double-clicking the file in My Computer or
Windows Explorer.

N O T E If Native Save and Open are disabled, a native dialog box will not
appear. For additional information, refer to “Restricting Users from
Accessing Interceptor Settings and Native Dialog Boxes” on page
116.
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5. From the native Word Open dialog box, locate the integration 
template POWERDOCSFOOTER.DOT or, if you use Word 2000, 
POWERDOCSFOOTER2000.DOT. The integration template is located 
in the PowerDOCS folder (by default, …\Program Files\ 
Hummingbird\PowerDOCS). Remember to change the Files of 
type field to Document Templates (*.DOT).

6. If you have Word set up to warn you when a document contains 
macros, the following dialog box is presented.

Click Enable Macros. 

Figure A.12

Word Macro Warning di-
alog box
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7. A Word document appears. Click the Install Macros button at the 
bottom of the page. If the Install Macros button is not visible, 

select Tools>Options>View from the menu bar and clear the Field 

Codes check box. 

A PowerDOCS information dialog box, like the one in Figure A.14, 

appears. Click OK. 

Figure A.13

PowerDOCS 
Automated Macro 
Installation Document

Figure A.14

The PowerDOCS infor-
mation dialog box 



8. Choose File>Close. Do not save changes to the integration 

template. You should, however, save changes to the global 

template NORMAL.DOT, if you are prompted to do so.

This process adds global macros containing PowerDOCS 

function calls to Word's Normal template.

9. Close Word.

Distribute this updated Normal.DOT file to your users.

Unintegrating
the Microsoft
Word Macros

Prior to uninstalling PowerDOCS, you must unintegrate the 

Microsoft Word Macros.

1. Start Word. Select File>Open.  If Word is integrated using 

ODMA, the Search Results dialog box is displayed. If you are not 

logged in to PowerDOCS, the login screen is displayed. 

2. If you are using ODMA integration, click Cancel to display a 

native Open dialog box. PowerDOCS will ask you if you want 

MS Word to open a document. Select Yes to display the native 

Open dialog box.  Proceed to step 4.

3. If you are using Passive Integration, you do not need to click 

Cancel. With Passive Integration installed, you only need to 

select File>Open to display a native dialog box.

4. Locate the integration template POWERDOCSFOOTER.DOT or, if 

you use Word 2000, POWERDOCSFOOTER2000.DOT. The 

integration template is located in the PowerDOCS folder (by 

default, \Program Files\Hummingbird\PowerDOCS).

N O T E If Native Save and Open have been disabled, the native dialog box
will not appear.
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5. If you have Word set up to warn you when a document contains 
macros, the following dialog box is presented. 

Click Enable Macros.

6. Click the Remove Macros button at the bottom of the page.

7. Select File>Close.

8. Exit Word, saving the changes to the NORMAL.DOT template. The 
integrated menu options have been removed from your system. 
Redistribute the Normal.DOT file to your users.

Figure A.15

Word Warning dialog 
box



Installing the
WordPerfect
Macro in the

Template

The WordPerfect Footer macro must be added to the WordPerfect 
document template.  Once the macro is added, distribute the updated 
template to your users.  The macro will be accessible to your users 
through the Tools>Macro menu.

1. Click File, New From Project.

2. Choose a category from the first list box, then choose a template 
from the second list box.

3. Click Options, Edit WP Template.

4. On the Template toolbar, click the Copy/Remove Object button. 

5. If the Template toolbar is not displayed, click View, Toolbars, 
then enable the Template check box. 

6. Choose the template that contains the macro from the Template 

7. To Copy From list box.

8. Choose Macros On Disk from the Object Type list box.

9. In the Macros On Disk section, click the Browse button.

10. Choose the drive where the macro is stored from the Look In list 
box.  The default location for the file is …\Program Files\ 
Hummingbird\PowerDOCS\PowerDOCSFooter.wcm.

11. Double-click the folder in which the macro is stored.

12. Click Select.

13. Click one of the following buttons: 

— Copycopies only selected items in the Source list box

— Copy Allcopies all items in the Source list box 

14. Click Close.

Distribute the new document template to your WordPerfect users.


