
MAX SAVE CARD WEB SITEMAX SAVE CARD WEB SITE

User DocumentationUser Documentation

Prepared by Lyons Digital Media, LLCPrepared by Lyons Digital Media, LLC
May 2009May 2009



Max Save Card Web Site
User Documentation

Last Updated: 05/22/09

Table of Contents
Project Background....................................................................................................................................4

Software.................................................................................................................................................4
Hosting Environment............................................................................................................................ 4
Technical Support..................................................................................................................................4
About this Document.............................................................................................................................4

Accessing the Web Site.............................................................................................................................. 5
Log in to the Max Save Card Web Site................................................................................................. 5

To Access the Public Web Site..........................................................................................................5
Forgotten Username or Password.....................................................................................................6
The User Menu................................................................................................................................. 6

Your Details................................................................................................................................. 6
To Access the Administration Area...................................................................................................7

Log Out of the Max Save Card Web Site.............................................................................................. 8
To Leave the Public Web Site...........................................................................................................8
To Leave the Administration Area....................................................................................................8

Creating Users............................................................................................................................................8
About Categories......................................................................................................................................10

Add a Category to the Max Save Card Web Site................................................................................ 10
Copy Categories.................................................................................................................................. 13
Moving Categories.............................................................................................................................. 15
Deleting Categories............................................................................................................................. 18

Directory Listings.................................................................................................................................... 19
Listings without Physical Address Information.................................................................................. 19
Add a Listing from the Public Web Site..............................................................................................20
Add a Listing from the Administration Area.......................................................................................23
Editing a Listing.................................................................................................................................. 26

Editing a Listing from the Administration Area............................................................................. 27
Editing a Listing from the Public Web site.....................................................................................28
Changing the Status of a Listing.....................................................................................................28

Deleting a Listing................................................................................................................................ 30
Deleting a Listing from the Public Web Site.................................................................................. 30
Deleting a Listing from the Administration Area........................................................................... 30

Copy and Move Listings..................................................................................................................... 32
Approve Listings................................................................................................................................. 32

View and Filter Pending Listings................................................................................................... 32
View and Approve Pending Listings.............................................................................................. 34

Quick Approve and Publish....................................................................................................... 34

Max Save Card Web Site User Documentation Page 2 of 65



Max Save Card Web Site
User Documentation

Last Updated: 05/22/09

Detail Review and Publish.........................................................................................................34
Delete a Pending Listing.................................................................................................................36

Geocoding................................................................................................................................................ 37
Geocoding New Listings..................................................................................................................... 37
Geocoding a New Category................................................................................................................ 38
Add an Item to the IP Geodirect Component...................................................................................... 40
The Change Location Menu................................................................................................................ 41

Creating Images....................................................................................................................................... 45
How to Change the Foreground Color in GIMP................................................................................. 45
Thumbnail Images...............................................................................................................................47

About Thumbnail Images............................................................................................................... 47
Creating Thumbnail Images........................................................................................................... 47

Listing Detail Images.......................................................................................................................... 52
About Listing Detail Images...........................................................................................................52
Creating Images for the Listing...................................................................................................... 52

Uploading Images.................................................................................................................................... 56
Uploading Thumbnail Images............................................................................................................. 56
Uploading Listing Detail Images........................................................................................................ 57

The Dummy Menu................................................................................................................................... 58
Max Save Card Registration Data............................................................................................................59

Access Blue Flame Forms...................................................................................................................59
Return to Joomla.............................................................................................................................60

View Registration Data....................................................................................................................... 60
Delete Registration Data..................................................................................................................... 61
Exporting Registration Data................................................................................................................62

Glossary................................................................................................................................................... 64

Max Save Card Web Site User Documentation Page 3 of 65



Max Save Card Web Site
User Documentation

Last Updated: 05/22/09

Project Background
The Max Save Card Web site was developed in March and April 2009 by Lyons Digital Media, LLC. 
The key features of the Web site are as follows:

Site visitors are identified by location and can search through a customized directory for Max 
Save Card discounts in their area. If the visitor desires, they can view offers in other areas 
served by Max Save Card dealers.

Site visitors can search for offers within a specified geographic area, using the site's Search 
feature.

Max Save Card Dealers can add businesses to their regional directories and assign business 
owners to a specific listing for offer maintenance purposes. Businesses can be added to the 
directory through either the public or private (administrative) areas of the site.

Software

The Web site, http://www.maxsavecard.com is based on Joomla version 1.5 content management 
system and uses a number of extensions and customized programming. The extensions used are 
Mosets Tree,  Zip Code Shop, Blue Flame Forms and JCE Editor. Customized programming was 
used to develop the Geodirect function, and to modify Mosets Tree and Joomla to meet the 
requirements of the Max Save Card Management Team.

The Max Save Card Web site is best viewed in Internet Explorer version 7.x and higher; Firefox 
version 3.x and higher; and Safari version 3.x and higher.

Hosting Environment

The Content Management System (CMS) and its extensions are hosted in a LAMP (Linux, Apache, 
MySQL and PHP) environment where all the key software components of the server, including 
operating system, database and scripting language are all Open Source Software (OSS) licensed 
under the Gnu Public License (GPL).

Technical Support

Please contact Lyonshost Support at support@lyonshost.com or 850-942-9442 if you have questions 
regarding the Max Save Card Web site or to report a problem.

About this Document

The document is to be used as a supplement to the documentation provided with Joomla version 1.5x, 
Mosets Tree and ZIP Code Shop. This document includes instructions for frequently used features of 
the Max Save Card Web site as well as features that were created or modified for Max Save Card.
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It is strongly recommended that Administrative users familiarize themselves with Joomla's base 
features and functions.

Cross-references are used through out the document and will allow the reader to navigate the 
document whether they are viewing the document in Acrobat Reader or in printed format. The 
following conventions are used throughout the document:

Clickable – indicates a link or icon to be clicked with the cursor (mouse)

Strong – indicates the title of a page, field or section of a Web page

Hyperlink – text that appears blue and underlined is cross referenced to another section of the 
document. Click the link to visit the page indicated.

Accessing the Web Site

Log in to the Max Save Card Web Site

To Access the Public Web Site

1. To access the Max Save Card Web site, open your preferred Web browser and type in the 
following into the address bar: http://www.maxsavecard.com.  

2. The Web site will load.

3. Scroll down to the bottom of the front page.

4. Click the Login link. The Login page will display.

5. Type your Username and Password into the fields provided.

NoteNote If you want the site to remember your Username and Password, 
select the Remember Me check box.

6. Click Login. 

7. The Home page will display. Note the addition of a User Menu.
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Forgotten Username or Password

In the event a registered user forgets their username or password, they can have the username sent to 
them or have the password reset.  In either case, the information is sent to the e-mail account on file 
for the user.  To retrieve a username or password:

1. Open your preferred Web browser and type in the following into the address bar: 
http://www.maxsavecard.com.  The Web site will load.

1. Scroll down to the bottom of the front page.

2. Click the Login link. The Login page will display.

3. Select one of the following links:

Forgot your Password?
Forgot your Username?

4. In the E-mail Address field, enter the e-mail address associated with your Max Save Card Web 
site account.

5. Click Submit.
6. The Login page will display.  An e-mail will be sent to the address associated with your 

account.
7. Retrieve your e-mail. A message titled “Your maxsavecard username” or “Your maxsavecard 

password” should appear in your Inbox.
8. Follow the instructions in the e-mail to either login with your username or reset your password.

The User Menu

The User Menu is only visible once a registered user has logged in to the Max Save Card Web site. 
There are only two options on the menu, Your Details and Logout. For Logout instructions, refer to 
page 8.

Your Details

The Your Details link gives a registered user the ability to change their display name, e-mail address, 
and password.  If a user changes their password, they will be required to reenter the password to 
verify it.

1. From the User Menu, click the Your Details link to access the Details page.
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2. Make the desired changes.

3. Click Save.

4. The Home page will display.

To Access the Administration Area

1. To access the Max Save Card Administration area, open your preferred Web browser and type 
in the following into the address bar: http://www.maxsavecard.com/administrator.  

2. The Joomla! Administration Login page will load.

3. Type your Username and Password into the fields provided.

4. Click Login. The Control Panel page will display.
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Log Out of the Max Save Card Web Site

To Leave the Public Web Site

1. Click the Logout menu item. It is located on the User Menu.

2. A confirmation page will display. Click Logout.

3. The Home page will display.

To Leave the Administration Area

Click the Logout link located in the upper right corner of the screen. The Joomla! 
Administration Login page will display.

Creating Users
Users of the Max Save Card Web site must be added manually to the database. This is a basic feature 
of Joomla and can only be accomplished through the Administration Area. 

NoteNote You must create a user account for any merchant that will be 
associated with a directory listing.

1. Log in to the Administration area. See To Access the Administration Area on page 7. 

2. The Control Panel page will display.

3. Click the User Manager icon.
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4. The User Manager page will display. Click the New icon in the upper right area of the page.

5. The User: [New] page will display.

6. Enter the listing information into the fields shown below. You may Tab between the fields.

Field Name Description

Name The name user.

Username The username that will be used to access the site. This should 
not contain any spaces.

E-mail The valid e-mail address of the user. 

Password The password to be used in combination with the Username. 
The password cannot contain spaces. A secure password 
should be used and contain a combination of letters, numbers 
and symbols. Ideally a randomly created password should be 
used. There are a number of password generator Web sites that 
can be used to create passwords.

Verify Password Enter the password again.

Group All users must be assigned to a group. Business owners that 
will be maintaining their listings should be assigned to 
Registered group.

7. Click the Save icon. It is located in the upper right area of the page.
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About Categories
The Mosets Tree application uses categories to organize information in the directory. In the Max Save 
Card Web site, business listings in the directory are assigned to a category.  The category may 
represent a state or a large metropolitan area. There are two types of categories descriptions that are 
used in this document: 

Top-level Category.  A top-level category is analogous to the label on the outside of a file 
drawer. It is the highest level of categorization assigned to a directory listing. In the Max Save 
Card  directory, a New York (state) would be considered a top-level category. 

ImportantImportant Top-level categories must be geocoded. Refer to 
Geocoding a New Category on page 38.

Sub-category.  A sub-category is related to a top-level category and is analogous to the label of 
a file folder in a file drawer. In the Max Save Card directory, you would place the sub-category 
of Manhattan within the New York top-level category. Additional sub-categories could be 
placed within the Manhattan category, for example: New York>Manhattan>Dry Cleaners.

Add a Category to the Max Save Card Web Site

Categories are used to contain groups of listings.

To add a new category to the site, follow these steps:

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.
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3. The Mosets Tree page will display. Note the navigation designations below:

4. In the Explorer section in the left pane, select the  Directory folder and click MaxSaveCard.

i. If adding a top-level category, do nothing and proceed to the Step 5.

ii. If adding a sub-category to an existing category, click that category. For example, click 
Indiana to add a sub-category to the Indiana directory, then proceed to Step 5.

5. In the upper left pane, click Add Category. The Add Category page will display. Note the 
addition of a Right Pane to the navigation area.

6. Enter the listing name in the Name field.
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7. Enter a Description, if desired. 

8. In the right pane, select the option buttons relating to the status of the listing: Published, 
Featured, and Allow listing submission.

9. If desired, enter META Keywords and a META Description. These items are used by search 
engines to rank the relevancy of a particular Web page.

TipTip Click Apply, located above the right pane, to do incremental 
saves of you work.

10. Click the Save icon, located above the right pane.

11. The new category will appear in the Explorer.

Max Save Card Web Site User Documentation Page 12 of 65



Max Save Card Web Site
User Documentation

Last Updated: 05/22/09

ImportantImportant If you added a category that is be the top-level category for a 
new Max Save Card region, you  need to geocode the new 
category and add the new region to the Change Location menu. 
Refer to pages 38 and 41.

Prior to doing this, record the new category's Category ID. It is 
shown in the This Category section in the right pane. Refer to 
the screenshot on the previous page.

Copy Categories

Once you have set up a top-level region category, you can copy sub-categories from other Max Save 
Card regions into the new top-level category.

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.

3. In the Explorer section in the left pane, select the  the Directory folder and click MaxSaveCard.

4. Select the region/category that contains the sub-categories you want to copy. The categories will  
appear in the center pane.

5. Select the categories you want to copy by selecting the check boxes next to the category names.

6. In the toolbar, click the Copy Categories icon.
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7. The Copy Category page will display. Using the category manager, select the category to 
which the selected categories should be copied.

8. In the options section, select the No option next to Copy Related Categories and Copy 
Listings. 
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9. Click the Save icon.  The new categories will be copied and will appear in the Explorer section.

Moving Categories

You can move categories within Mosets Tree. This may be necessary if a sub-category was added to 
the wrong region or if a business has moved within a region.

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.

3. In the Explorer section in the left pane, select the  the Directory folder and click MaxSaveCard.

4. Select the region/category that contains the sub-categories you want to move. The categories 
will appear in the center pane.
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5. Select the categories you want to move by selecting the check boxes next to the category 
names.

6. In the toolbar, click the Move Categories icon.
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7. The  Move Category page will display. Using the category manager, select the category to 
which the selected categories should be moved.

8. Click the Save icon.  The category will be moved and will appear in the Explorer section.
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Deleting Categories

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.

3. In the Explorer section in the left pane, select the Directory folder and click MaxSaveCard.

i. If deleting a top-level category, select the category to be deleted.

ii. If deleted a sub-category, continue drilling down to the category housing the item to be 
deleted. Select the category to be deleted.
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4. Click the Delete icon.

5. You will be asked to confirm the action.  Click Delete to continue or Cancel to quit.

Directory Listings
Businesses offering Max Save Card discounts must be entered into the database. Listings are 
assigned to a top-level region category and a service or topic specific sub-category. For example, 
Indiana>Recreation.

Listings can be added from either the front end (public) Web site or through the Administration area. 
If the listing will be assigned to a merchant, you must enter the listing through the public Web site. 

ImportantImportant Prior to assigning a merchant to a directory listing, the 
merchant must have a user account created. Refer to 
Creating Users on page 8.

Listings without Physical Address Information

For businesses with no physical address, you must still enter a street address or ZIP code in order to 
geocode the listing. You can use the home address of the business owner or the ZIP code of a local 
landmark.

After the listing is coded, you can delete the street address or ZIP code information. Refer to 
Geocoding a New Category on page 38 for helpful tips.
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Add a Listing from the Public Web Site

1. Log in to the Web site. See To Access the Public Web Site on page 5.

2. Navigate to the Area and Category applicable to the listing. In this example, the Area is 
Tallahassee and the Category is Health & Beauty.

3. On the right, note the link Add your listing here. Click the link. The Add Listing page will 
display.

4. Before proceeding, verify that the Area and Category listings are correct.
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5. Enter the listing information into the fields shown below. You may Tab between the fields.

Field Name Description

Name The name of the business.

Description A brief description of the business and the services it offers.

Address The street address of the business. Be sure to add a Building 
or Suite designation if required.

City City where the business is located.

State State where the business is located.

ZIP code Five digit ZIP code.

Telephone Telephone number including area code.

Fax Fax number including area code.

Website Web site address of the business. Be sure to add the http:// 
prefix.

Cardholder Discount The discount or offer given to a Max Save Cardholder. The 
field is limited to 256 characters.

Expires on The date on which the offer expires. Enter in the 
MM/DD/YYYY format.

Cardholder Discount If applicable, enter the second discount or offer given to a 
Max Save Cardholder. The field is limited to 256 characters.

Expires on The date on which the offer expires. Enter in the 
MM/DD/YYYY format.
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Field Name Description

Assign to User If this listing should be assigned to a merchant for editing 
purposes, select the username in this field. By default, the 
listing will be assigned to the logged-in user entering the 
information.

If the person to whom you want to assign the listing is not 
shown, you need to have an Administrator create a user 
record.  Refer to Creating Users on page 8 for more 
information.

6. The following fields are optional and require advance preparation:

Field Name Description

Thumbnail Image The thumbnail image is used in the top-level category listing 
as well as in the Featured Listing column. Refer to Thumbnail  
Images on page 47 for more information.

Add Images to Listing 
(Limit 3)

You can add up to three additional images to the listing. These 
may be pictures of the exterior or interior of the business, the 
grounds, or other features deemed important by the business 
or listing owner. Refer to Uploading Images on page  56 for 
additional information.

7. The Latitude and Longitude information is generated from the Administration Control Panel. 
Refer to Geocoding New Listings on page 37 for more information.

8. Click Submit to save the Listing Record. 

TipTip If you need to stop entering information into the listing, click 
Cancel to leave the page or Save the listing and change 
the status to Unpublished using the Administration Control 
Panel.

9. The Category page will display. All new listings and edits are held for approval. You will 
receive an e-mail confirming that the listing was submitted and again when the listing is 
approved.
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Add a Listing from the Administration Area

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.

3. On the left, click Add Listing. The Add Listing page will display. Note the navigation areas 
labeled on the image below.
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5. Navigate to the Area and Category applicable to the listing. Drill down to the desired category 
by clicking MaxSaveCard then the Area and Category.

In this example, the Area is Tallahassee and the Category is Shopping.

NoteNote You can assign a listing to more than one category. Click Also 
appears in this category to make a another category selection.

If you need to make a correction, click the Back item in the 
Manage Category box.

6. Click Update Category. The selected category will appear in bold.
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7. Enter the listing information into the fields shown below. You may Tab between the fields.

Field Name Description

Name The name of the business.

Description A brief description of the business and the services it offers. 
You can use the WYSIWYG editor to apply the Paragraph 
Style or make other formatting changes.

Address The street address of the business. Be sure to add a Building 
or Suite designation if required.

City City where the business is located.

State State where the business is located.

ZIP code Five digit ZIP code.

Telephone Telephone number including area code.

Fax Fax number including area code.

Website Web site address of the business. Be sure to add the http:// 
prefix.

Cardholder Discount The discount or offer given to a Max Save Cardholder. The 
field is limited to 256 characters.

Expires on The date on which the offer expires. Enter in the 
MM/DD/YYYY format.

Cardholder Discount If applicable, enter the second discount or offer given to a 
Max Save Cardholder. The field is limited to 256 characters.

Expires on The date on which the offer expires. Enter in the 
MM/DD/YYYY format.
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Field Name Description

Owner If this listing should be assigned to another owner for editing 
purposes, type the username in this field. 

If the person to whom you want to assign the listing is not 
shown, you need to have an Administrator create a user 
record. Refer to Creating Users on page 8 for more 
information.

8. The following fields are optional and require advance preparation:

Field Name Description

Thumbnail Image The thumbnail image is used in the top-level category listing 
as well as in the Featured Listing column. Refer to Thumbnail  
Images on page 47 for more information.

Add Images to Listing 
(Limit 3)

This feature is located in the right pane. 

You can add up to three additional images to the listing. These 
may be pictures of the exterior or interior of the business, the 
grounds, or other features deemed important by the business 
or listing owner. Refer to Uploading Images on page  56 for 
additional information.

9. The Latitude and Longitude information is generated from the Administration Control Panel. 
Refer to Geocoding New Listings on page 37 for more information.

10. In the left pane, select the desired options to Approve, Publish or Feature the listing.

11. Click Save to save the Listing Record. 

12. The Listing page will display. If you approved and published the listing, the listing will be 
immediately visible from the public Web site. If you featured the listing, it will appear in the 
Featured Offers column on the public Web site.

Editing a Listing

Listings can be modified from either the Administration Area or the public Web site.

TipTip When editing a listing in the Administration Area, you can set a 
listing to start or stop publishing on a specific date by changing 
the entries in the Start Publishing and Finish Publishing fields.
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Editing a Listing from the Administration Area

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.

3. In the left pane, expand the Directory folders and select the category where the listing to be 
edited is assigned. In this example, the selection is MaxSaveCard>Tallahassee>Shopping.

4. The listings in the selected category will be shown in the center pane. Click the Listing name of 
the item you want to edit.

5. Make any changes desired including changing the publishing or Featured Listing information.
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Editing a Listing from the Public Web site

A site user can edit only the listings assigned to them.

1. Log in to the public Web site area. See To Access the Public Web Site on page 5.

2. Navigate to the category containing the listing. In this example, the selection is 
MaxSaveCard>Tallahassee>Shopping.

3. Note the Edit link next to the business name. Click this link.

4. The Edit Listing page will display. Make any changes desired.

5. Click Submit.

Changing the Status of a Listing

A listing's status can only be changed from the Administration Area. You can perform the following 
functions:

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.

3. In the left pane, expand the Directory folders and select the category where the listing to be 
edited is assigned. In this example, the selection is MaxSaveCard>Tallahassee>Shopping.
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4. The listings in the selected category will be shown in the center pane. To the right of the Listing 
name are two icons, Featured and Published.

5. To add a listing to or remove a listing from the Featured Offers area, click the Featured icon. In 
the example above, Jonathan Camera is not a Featured listing.

6. To publish or unpublish a listing, click the Published icon. In the example, Jonathan Camera is 
published, and therefore visible in the directory. 

An Active Featured Listing An Unpublished Listing
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Deleting a Listing

Deleting a Listing from the Public Web Site

A site user can edit only the listings assigned to them.

1. Log in to the public Web site area. See To Access the Public Web Site on page 4.

2. Navigate to the category containing the listing. In this example, the selection is 
MaxSaveCard>Tallahassee>Health & Beauty.

3. Click the Name link. In this example, the business name is Barbara's Salon.

4. The Listing Detail page will display. 

5. Click Delete.

6. A confirmation message will display. Click Delete to continue or Cancel to return to the 
Listing Detail page.

Deleting a Listing from the Administration Area

If you need to delete a listing, follow the instructions below.

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.
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3. In the left pane, expand the Directory folders and select the category where the listing to be 
edited is assigned. In this example, the selection is MaxSaveCard>Tallahassee>Auto Service 
& Repair.

TipTip You can use the Search field in the left pane to find a listing by 
name.

4. The listings in the selected category will be shown in the center pane. 

5. Select the checkbox next to the listing you want to delete.

6. Click the Delete Listing icon in the top right part of the page.

7. The listing is deleted immediately.
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Copy and Move Listings

You can copy and move individual listings in the same manner as you Copy Categories and Move 
Categories except you select the Copy Listings and Move Listing icons. Refer to pages 13 and 15.

Approve Listings

When listings are added to directory, or when a merchant makes a change to an offer, the directory 
entries need to be approved and published.

View and Filter Pending Listings

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the menu, select Components>Mosets Tree.

3. The Mosets Tree page will display. In the Explorer section in the left pane, locate the Awaiting 
Approval block.
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4. Click Listings (x), where x is the number of listings to be approved. The Pending Listings will 
display in the center pane.

5. To filter the list to show only your pending listings, click the drop-down arrow next to the Sort 
by category field.

6. Select the desired category and the listings in the center pane will show only those assigned to 
the category.

TipTip To return to the All Listings view, select All in the Sort by 
category field.
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View and Approve Pending Listings

Once you have sorted the pending listings, you can go approve and publish them. There are two ways 
to do this, as outlined below.

Quick Approve and Publish

If you entered a listing and know that all information is correct, you can do a Quick Approve and 
publish the listing immediately. 

1. Navigate to the Pending Listings page. Refer to View and Filter Pending Listings on page 32.

2. Select one or more listings one or more listings on the Pending Listing page. To do this, select 
the check box next to the listing title.

3. Above and to the right of the list, click the Approve & Publish Listing icon.

4. The screen will refresh and the listing will be published immediately.

Detail Review and Publish

If you are approving listings entered by others or edits made by a merchant assigned to a listing, you 
may want to do a detailed review of the listing prior to publishing it.

1. Navigate to the Pending Listings page. Refer to View and Filter Pending Listings on page 32.

2. Click the title of the listing you want to review.

3. The Edit Listing page will display.
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4. At the top of the page, you have the ability to Ignore, Approve, or Reject the listing after you 
review it. If changes are needed, proceed to Step 5.

i. If no changes are needed, click the Approve button. The listing will be published 
immediately after you click Save.

ii. If you want to defer the review process, click the Ignore button. You will return to the 
Pending Listing page immediately after you click Save.

iii. If you want to reject the listing, click the Reject button. The listing will be deleted 
immediately after you click Save.

5. Modify the fields on the page as desired, including changing the Publishing, Approved, and 
Featured Listings options.
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TipTip You can set a listing to start or stop publishing on a specific date 
by changing the entries in the Start Publishing and Finish 
Publishing fields.

6. Click the Save Changes icon in the upper right corner.

Delete a Pending Listing

If it is necessary to delete a pending listing without a review, follow the steps outlined below.

1. Navigate to the Pending Listings page. Refer to View and Filter Pending Listings on page 32.

2. Select one or more listings one or more listings on the Pending Listing page. To do this, select 
the check box next to the listing title.

3. Above and to the right of the list, click the Delete Listings icon.

4. The pending listing is removed immediately.
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Geocoding
Geocoding is the process where a new Max Save Card area category or directory listing is assigned 
its latitude and longitude location. 

ImportantImportant Without the latitude and longitude information, the site 
cannot display categories and directory listings for a 
specific geographic areas.

Latitude and longitude information is also necessary for 
the IP Geodirect feature to work. This is the feature that 
makes Max Save Card Web site display geographic 
offer information for a visitor, based on that visitor's IP 
address. Refer to page 40.

It is necessary to perform the geocoding task on a regular basis so that directory listings appear in the 
correct geographic category. You may geocode after every entry in the database or after you have 
entered a batch of new listings.

To geocode a new listing, proceed to page 37.

To geocode a new category, proceed to page 38.

Geocoding New Listings

When new listings are added to the directory, they need to have the geographic location information 
entered into the database. This is done through the Administration Area of the Max Save Card Web 
site. To geocode new listings, follow these steps:

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. The Control Panel page will display. Select Components>MT ZCS Search>Geocode.
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3. The MT ZCS Geocoding page will display. Verify that the Overwrite existing values? field is 
set to No.

4. Click Start.  A pop-up status window will appear.

5. Depending on how many entries need to be coded, the process may take anywhere from a few 
minutes to over an hour. If you need to cancel the geocoding process, click Cancel.

i. You will need to confirm that you want to cancel. Click Cancel again. 

ii. Click OK to stop the process.

Geocoding a New Category

If you have added a category as a new top-level area category, you need to geocode the area and then 
add it to the IP Geodirect component and the Change Location menu.

1. Create a new listing in the new top-level category. Refer to Add a Category to the Max Save 
Card Web Site on page 10.

Enter the Name as Geocode Test Listing.

The address can be the business address of the Max Save Card representative or an address 
near the geographic center of the area represented by the category.  In this example, New 
York is the category and the address being used is for Grand Central Station.
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Note that the listing has been set as Approved and Published. That is fine for now. You will 
delete the listing after you have tested the new Change Location menu item. Refer to page 41.

2. Click the Save icon.

3. Geocode the listing. Refer to Geocoding on page 38.

4. Reopen the Geocode Test Listing in Edit mode. Refer to Editing a Listing on page 26. The 
latitude and longitude information was added to the record.

5. Record this information by either writing it down or copy and paste it into a simple text file 
using Notepad (Windows) or TextEdit (Mac).
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6. Click Cancel to exit the page.

7. Continue to the next section, Add an Item to the IP Geodirect Component on page 40.

Add an Item to the IP Geodirect Component

One of the key features of the Max Save Card Web site is its ability to direct a visitor to the Directory 
Listings within 200 miles of the visitors IP address. For this feature to work, the Max Save Card 
region needs to be added to the IP Geodirect Component. You will need the following pieces of 
information:

The Latitude and Longitude information from the Geocode Test Listing. Refer to page 38.

The Category ID from the Mosets Tree component. Refer to page 10.

The starter URL, which is:

option=com_content&view=category&layout=blog&id=34&cat_id=XX&Itemid=69 

To add the new region, follow these steps:

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. The Control Panel page will display. Select Components>IP Geodirect.

3. The IP Geodirect page will display. Click the New icon.

Max Save Card Web Site User Documentation Page 40 of 65



Max Save Card Web Site
User Documentation

Last Updated: 05/22/09

4. The New Url page will display. Enter the following information into the fields provided:

Field Name Description

Url This is the base URL shown on the previous page, except that 
the value of XX has been replaced with the Category ID. In 
our example of New York which has a category ID of 143, the 
URL would be as follows:

option=com_content&view=category&layout=blog&id=34&c
at_id=143&Itemid=69 

Latitude The latitude result from the Geocode Test Listing.

Longitude The longitude result from the Geocode Test Listing.

Merchant Key The name of the region.

5. Click the Save icon. Proceed with adding the new region the the Change Location menu. Refer 
to page 41.

The Change Location Menu

Whenever a new region is added to the Max Save Card directory in Mosets Tree, you need to add this 
new region to the Change Location Menu. Prior to doing this, the region must be entered in the IP 
Geodirect Component. Refer to page 40 for more information. You will need the following 
information to proceed:

The Category ID from the Mosets Tree component. Refer to page 10.

The starter URL, which is:

index.php?option=com_mtree&task=listcats&cat_id=XX&Itemid=69 
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1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. The Control Panel page will display. Select Menus>Change Location.

3. The Menu Item Manager page will display. Click the New icon.

4. The Menu Item: [ New ] page will display. Click External Link.

5. The New Menu Item page will display. Enter the information into the fields provided:

Field Name Description

Title The title of the listing. In this example, the title is New York.

Link Enter the base URL, except exchange the XX for the category ID of 
the new region. In our example of New York which has a category ID 
of 143, the URL is:

index.php?option=com_mtree&task=listcats&cat_id=143&Itemid=69 

Parent Item If the new menu item should appear as a top-level menu, leave the 
default setting of Top. If this is a sub-category of another region, 
select the appropriate top-level region.

Merchant Key The name of the region.
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6. Click the Save icon.

Next, test the new menu item.

1. Click the Preview link in the upper right area of the page. A new tab or new window will open 
in your browser.

2. Switch to the new window or tab.

3. Click the Change Location menu item.
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5. Click the new menu item.

6. The page will refresh and you will see the Geocode Test Listing.

7. Delete the Geocode Test Listing. Refer to Deleting a Listing on page 30.
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Proceed with adding categories and listings to the new Max Save Card region. Refer to pages 10 and 
19.

Creating Images
You can feature a small version of a business' logo in the Category and Detail listings in the Max 
Save Card Directory. 

The business owner can provide you with an image in the correct dimensions or you can create it 
using an image editing program. There are many image editing programs available. Below is a partial  
list of products that can be used.

Name Platform

Photoshop Windows or Mac

Photoshop Elements Windows

The GIMP Windows or Mac (Free)

Paint Shop Pro Windows

Pixelmator Mac

The instructions in this document are for using GIMP, a free image editing program available for 
Windows and Mac. If you are familiar with another image editing program, you should be able to 
modify the instructions for your application.

How to Change the Foreground Color in GIMP

If you want the excess background of the images you create to match the background of the Max 
Save Card Web site, follow the instructions below.

1. Open GIMP.

2. Click the Foreground item in the Toolbox.

3. The Change Foreground Color dialog box will open.
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4. In the HTML Notation field, type 580107. 

5. Click OK.
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Thumbnail Images

Thumbnail images are small images used in a Web  site. They are usually small and often serve as a 
preview image.

About Thumbnail Images

Thumbnail images must be created to the following specifications:

80 x 100 pixels

72 dpi

Here is an example of a thumbnail image in the correct dimensions and resolution:

100 pixels wide

80 pixels tall

Creating Thumbnail Images

1. Open GIMP.

2. Select File>Open.

3. Browse and select the image to be edited.
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4. Click Open. The image will open, as shown below.

5. To resize the image, select Image>Scale Image. The Scale Image dialog box will display.

6. Change the Height to 80 pixels.

7. Verify that the Resolution is set to 72.000 pixels/in.

NoteNote If changing the height to 80 results in a width greater than 100 
pixels, change the width to 100. When you change the canvas 
size in Step 9, change the height to 80 pixels.

8. Click Scale. The image size will be reduced.
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9. Next, adjust the size of the canvas by selecting Image>Canvas Size. The Set Image Canvas 
Size dialog box will display.

10. Click the chain icon that is to the right of the Width and Height fields. Doing so will allow you 
to adjust the either dimension independently of the other.

11. Change the Width to 100 pixels.

12. In the Offset section, click the Center button.

Max Save Card Web Site User Documentation Page 49 of 65



Max Save Card Web Site
User Documentation

Last Updated: 05/22/09

13. Click Resize.

14. Blank space will be shown on either side of the main image.

15. Select Layer>New Layer. The New Layer dialog box will display.

16. In the section Layer Fill Type, click the Foreground option.

NoteNote If you do not want to use the foreground color, select White to 
fill in the excess area with that color. Refer to page 45 for more 
information.

17. Click OK. The image will be hidden by the new layer.

18. Select Layer>Stack>Reverse Layer Order.  The image will display correctly.
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19. Select Image>Flatten Image.

20. Select File>Save As.

21. If desired, rename the file in the Name field.

22. Navigate to the folder into which the file should be stored.

NoteNote You may want to create a specific folder on your computer to 
store these images.

23. Expand the section Select File Type (by extension).

24. Select JPEG.

25. Click Save. The Save as JPEG dialog box will display.

26. Click Save.

27. Repeat steps 2 – 26 for the next thumbnail image.

28. When all images have been processed, select File>Quit.
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Listing Detail Images

About Listing Detail Images

Thumbnail images must be created to the following specifications:

200 x 150 pixels,

72 dpi, and

No larger than 512K in size.

Here is an example of a listing image in the correct dimensions and resolution:

200 pixels wide

150 pixels tall

You can insert up to three separate images into the listing's detail page. 

Creating Images for the Listing

1. Open GIMP.

2. Select File>Open.

3. Browse and select the image to be edited.

4. Click Open. The image will open, as shown below.
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5. To resize the image, select Image>Scale Image. The Scale Image dialog box will display.

6. Change the Width to 200 pixels.

NoteNote If changing the width to 200 results in a height greater than 150 
pixels, change the height to 150. When you change the canvas 
size in Step 9, change the width to 200 pixels.

7. Verify that the Resolution is set to 72.000 pixels/in.

8. Click Scale. The image size will be reduced.
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9. Next, adjust the size of the canvas by selecting Image>Canvas Size. The Set Image Canvas 
Size dialog box will display.

10. Click the chain icon that is to the right of the Width and Height fields. Doing so will allow you 
to adjust the either dimension independently of the other.

11. Change the Height to 150 pixels.

12. In the Offset section, click the Center button.

13. Blank space will be shown on either side of the main image.
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14. Click Resize.

15. Select Layer>New Layer. The New Layer dialog box will display.

16. In the section Layer Fill Type, click the Foreground option.

NoteNote If you do not want to use the foreground color, select White to 
fill in the excess area with that color. Refer to page 45 for more 
information.

17. Click OK. The image will be hidden by the new layer.

18. Select Layer>Stack>Reverse Layer Order.  The image will display correctly.

19. Select Image>Flatten Image.

20. Select File>Save As.

21. If desired, rename the file in the Name field.

22. Navigate to the folder into which the file should be stored.

NoteNote You may want to create a specific folder on your computer to 
store these images.

23. Expand the section Select File Type (by extension).
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24. Select JPEG.

25. Click Save. The Save as JPEG dialog box will display.

26. Click Save.

27. Repeat steps 2 – 26 for the next image.

28. When all images have been processed, select File>Quit.

Uploading Images
Uploading is the process by which files are added to a storage folder on the server. The Max Save 
Card Web site allows specific image files to be associated with listing. Directory listings can have a 
thumbnail image and three additional images on the listing's detail page. You must have the images 
prepared before uploading them. Refer to Creating Thumbnail Images on page 47 and Creating  
Images for a Listing on page 52. 

Uploading Thumbnail Images

The process to upload thumbnail images is the same, regardless of where the user logs in. These 
instructions assume:

You are logged in to either the Public Web site or Administration Area and

You are entering or editing a listing.

1. Click the Browse button next to the Thumbnail Image field. The File Upload dialog box will 
display.

2. Navigate to the folder location where the thumbnail image was stored.

3. Select the file by clicking on it one time.

4. Click Open.  The file path will appear in the Thumbnail Image field.
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After the listing is saved, the thumbnail image will appear in the Directory as well as within the Edit 
view of the listing.

If you want to disable the thumbnail image and use the default Max Save Card logo image, clear the 
check box next to the image.

Uploading Listing Detail Images

The process to upload thumbnail images is the same, regardless of where the user logs in. These 
instructions assume:

You are logged in to to either the Public Web site or the Administration Area, and

You are entering or editing a listing.

1. Click the Add Images to Listing link.

2. A blank field will display.

3. Click Browse. The File Upload dialog box will display.

4. Navigate to the folder location where the thumbnail image was stored.

5. Select the file by clicking on it one time.

6. Click Open.  The file path will appear in the field.

7. If you selected the wrong file, click Remove. Repeat Steps 1 through 6.

8. To add another image, click the Add Images to Listing link. Another field will display.

After the listing is saved, the images will appear in the Directory as well as within the Edit view of 
the listing.
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If you want to disable the detail images, clear the check box next to the image.

The Dummy Menu
In order to accomplish some of the features of the Max Save Card Web site, an invisible (dummy) 
menu has been created in Joomla.  It is located in Menus>Dummy Menu. Under no circumstances 
should this menu or its items be modified or removed. Please contact Lyonshost Support at 
support@lyonshost.com or 850-942-9442 if you have questions regarding this menu.
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Max Save Card Registration Data
When Max Save Cardholders register their cards and e-mail addresses on the Max Save Card Web 
site, the information is saved in a database on the server.  Users with access to the Administration 
Area can view, edit, and export this information.

NoteNote Because the Max Save Card registration data is stored in a 
database table, the data cannot be edited from the Blue Flame 
Forms component.

Access Blue Flame Forms

1. Log in to the Administration area. See To Access the Administration Area on page 7.

2. In the Components menu, select Blue Flame Forms For Joomla. The Quick Start Guide for 
Blue Flame Forms page will display.

3. Select Your Forms. The Your Forms page will display.

4. Select Max Save Card Registration.
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The Quick Start Guide for Blue Flame Forms page will display. Take note that the top of the 
page indicates the current form.

5. Proceed with Viewing or Exporting the registration data.  Refer to pages 60 and 62.

Return to Joomla

At any time, you can leave the Blue Flame Forms area by clicking the Exit to Joomla icon in the 
upper left corner of the page.

View Registration Data

The instructions below assume that you have accessed the Blue Flame Forms Quick Start Guide page 
for the Max Save Card Registration Form. Refer to Access Blue Flame Forms on page 59.

1. Select the Submissions menu item on the left.

2. The Submissions Manager page will display. All recently entered registration data will be 
shown.
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3. You can sort the data in the table by clicking the column headings. In the example below, the 
data is being sorted by ZIP code.

i. You can Delete items in the table. Refer to the instructions on page 61.

ii. You can Export data from the table. Refer to the instructions on page 62.

iii. You can return to the Joomla Administration Area. Refer to the instructions on page 60.

Delete Registration Data

1. Select the check box next to the registration record to be edited.

2. Click the Delete icon. 

3. A confirmation message will appear. Click OK to proceed or Cancel to close the message.
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Exporting Registration Data

The instructions below assume that you have accessed the Blue Flame Forms Quick Start Guide page 
for the Max Save Card Registration Form. Refer to Access Blue Flame Forms on page 59.

1. Select Export Data in the left menu. The Export Options page will display.

2. The two options most applicable to the Max Save Card Team use are Export Form Submissions 
to CSV and Export Form Submissions to CSV (Microsoft Excel Specific Encoding). Either file 
format can be imported into a spreadsheet or database program for additional processing or 
manipulation.

3. For this example, select Export Form Submissions to CSV (Microsoft Excel Specific 
Encoding). Depending on your browser, the file will either be opened in MS Excel or you will 
be asked to either Save or Open the file.
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4. In this example, the file was opened with OpenOffice.org, a free, open source office software 
suite.

5. You may be asked to confirm the file type and delimiter in the file. If the column breaks in the 
preview appear accurate, click OK.
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6. The spreadsheet will open and the data will be displayed. You can save the file as CSV or in 
another spreadsheet format, as desired.

Glossary
Below is a list of terms commonly used in this document or in the Max Card Save Web site.

Term Description

Administration Area The password-protected administration area of a Joomla Web 
site. Only users assigned Administrator or Super-
Administrator status can access this area.

CMS Content Management System – a dynamic, database driven 
Web site.

CSV Comma Separated Value. A file format used to organize text 
data in tabular format. Lines of information are separated by 
commas. This data file can be easily imported into most 
spreadsheet and database programs for additional 
manipulation.

Directory A listing of Max Save Card region categories, sub-categories 
and listings.

Geodirection The function whereby a Web site visitor's physical location is 
determined from their IP Address, and the content on the Web 
site is customized for the user's location.

GIMP The GNU Image Manipulation Program, a free image editing 
program for Windows and Mac computers.

Icon A graphic symbol (usually a simple picture) that denotes a 
program or a command

IP Address A unique identifier of computers and/or networks linked to the 
Internet.
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Term Description

Joomla The CMS application used for the Max Save Card project.

Login The process of accessing a Web site by entering a username 
and password in the provided fields. 

Logout The process of signing out of a Web site. 

META Data and META 
keywords

Metadata is information about a content item that is not 
displayed but is available to Search Engines and other systems 
to classify the content item.

Excellent documentation on using the META fields in Joomla 
is available in the Joomla! Help under the topic Article 
Manager: New/Edit.

Open Source Software Open source is a development method for software that 
harnesses the power of distributed peer review and 
transparency of process.  From Opensource.org.

Pane A term used to divide a Web page into discreet sections.

Pixel One picture element. The smallest discrete element which 
makes up an image.

Thumbnail Image A small image used as a placeholder or icon.

Toolbar A collection of icons grouped together on a Web page or 
within an application.

URL Universal Resource Locator – another name for a Web site 
address.
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